critical Cve 2026 119977 · Exploits

WordPress Core Upgrade-Window RCE CVE-2026-119977 Is on CISA KEV: Fixed in 7.1.4 and 24 Backports

Data graphic: CVSS 8.1 unauthenticated WordPress upgrade-window RCE, CVE-2026-119977, affecting WordPress 4.7 through 7.1.3, exploited and on CISA KEV with a 6 Nov 2026 due date, fixed in 7.1.4 and 24 backports.
TM

Exploit intelligence researcher · Published Nov 5, 2026, 1:48 AM EST

CISA lists WordPress Core 4.7 to 7.1.3 upgrade-window RCE CVE-2026-119977 as exploited, due 6 November. The fixed build for every branch, and how to check yours.

CISA added a WordPress Core remote code execution flaw, CVE-2026-119977, to its Known Exploited Vulnerabilities catalog on 3 November 2026, with a federal remediation due date of 6 November. Every WordPress release from 4.7 through 7.1.3 is affected, and the fix is WordPress 7.1.4 or the matching security release for older branches. CISA's SSVC data in NVD records exploitation as "active".

What is affected

NVD's record says WordPress Core 4.7 through 7.1.3 is vulnerable "due to predictable, web-accessible staging paths used during full-package core upgrades". An unauthenticated attacker can execute code on the server during the upgrade window. The CNA, Wordfence, scored it CVSS 3.1 8.1 (High): network vector, no privileges, no user interaction, but attack complexity High. That rating fits a flaw that only exists while a core upgrade is in progress. CISA classes it as CWE-367, a time-of-check time-of-use race, and its KEV entry is titled "WordPress WordPress Core Time-of-check Time-of-use (TOCTOU) Race Condition Vulnerability".

NVD published the record on 31 October. In KEV, known ransomware campaign use is "Unknown". No source we read names an attacker or campaign, and this article does not either.

How the fix and the CVE are linked

The WordPress 7.1.4 announcement of 28 October does not name a CVE. It lists "a weakness in the upgrade process that could allow remote code execution during the upgrade window" among the fixes. The match to CVE-2026-119977 rests on NVD's references, which list that post as the release note and point to Trac lines in the 7.1.4 tag (class-wp-upgrader.php and update-core.php) as the patch. We could not open the Trac pages or the Wordfence advisory, so the exact mechanism is not described here.

The same release also fixes a batch of stored XSS issues, an Interactivity API denial of service, exposure of unpublished Customizer changesets and a bundled root certificate update, so it is worth installing for more than this one flaw.

Fixed builds per branch

The WordPress.org version-check API and the releases page both listed, on 5 November, a release for every branch below. NVD's configuration data gives the same numbers as the first non-vulnerable build in each branch. Anything older than the build listed for your branch is affected.

BranchFixed build
7.17.1.4
7.07.0.8
6.9 / 6.8 / 6.7 / 6.66.9.11 / 6.8.12 / 6.7.11 / 6.6.11
6.5 / 6.4 / 6.3 / 6.26.5.14 / 6.4.14 / 6.3.14 / 6.2.15
6.1 / 6.06.1.16 / 6.0.18
5.9 / 5.8 / 5.7 / 5.65.9.20 / 5.8.19 / 5.7.21 / 5.6.23
5.5 / 5.4 / 5.3 / 5.25.5.24 / 5.4.25 / 5.3.27 / 5.2.30
5.1 / 5.05.1.28 / 5.0.31
4.9 / 4.8 / 4.74.9.35 / 4.8.34 / 4.7.39

The 7.1.4 announcement said the backports were still in progress when it was published. They are now available.

Data graphic: timeline for CVE-2026-119977: WordPress 7.1.4 released 28 Oct 2026, NVD publishes the CVE 31 Oct, CISA adds it to KEV 3 Nov, federal remediation due 6 Nov.

From the WordPress 7.1.4 release to the federal remediation deadline.

What defenders should do

  1. Check your version. In the dashboard, open Dashboard > Updates, which shows the installed version. With WP-CLI, run wp core version. Compare the result with the table above.
  2. Update now. Use Dashboard > Updates > Update Now, or run wp core update to fetch the latest release for your install. Sites with background updates enabled may already have moved, but confirm it. For a pinned older branch, use wp core update --version=<fixed build> with the number from the table.
  3. Treat the upgrade itself as the risky moment. The flaw lives in the upgrade window, so schedule updates promptly and do not leave a half-finished upgrade sitting on a public site.
  4. Triage for compromise if you were exposed. The KEV entry flags forensic triage as required and cites CISA's BOD 26-04 and its forensic triage requirements. We found no public indicators of compromise as of 5 November 2026, and we will not guess at any. Preserve logs and file listings, and follow CISA's triage guidance for any system that was reachable during an upgrade before it was patched.

Federal agencies have until 6 November. Everyone else has the same flaw and the same fix. Our earlier WordPress core coverage, CVE-2026-87902, is a separate issue.

Sources

Keep reading

All latest →
  1. criticalExploitsCISA Adds Magento PolyShell Upload Flaw CVE-2026-48356 to KEV: Fixed Builds and How to Hunt for Webshells4 min
  2. elevatedExploitsCISA Adds a Low-Severity VMware ESX Logging Flaw to KEV, a Gap That Lets Admin Actions Go Unrecorded3 min
  3. highExploitsJuniper Patches Two CVSS 9.8 Flaws in Session Smart Router and Conductor, With No Workaround3 min
  4. highExploitsCisco ASA and FTD SSL VPN Crash Flaw CVE-2026-76418 Is Being Exploited; CISA Sets a 1 November Deadline4 min
  5. highExploitsAdmin-Only Fortinet Flaw CVE-2025-61624 Used to Gain Root, Now on CISA KEV4 min
  6. highExploitsSiemens Software Center DLL flaw CVE-2026-110936 exploited in ClickFix attacks4 min